Back to overview
Resolved

Records database is experiencing degraded performance

Sep 13, 2026 at 11:00pm UTC
Affected services
Nango Cloud Health

Resolved
Sep 14, 2026 at 3:02am UTC

This issue has been resolved

Updated
Sep 14, 2026 at 2:35am UTC

We have mitigated the issue and will continue observing the service behavior.

Created
Sep 13, 2026 at 11:00pm UTC

Some syncs may be failing to persist records. We are investigating the root cause.