Back to overview
Degraded

Actions backlogged

Feb 15 at 12:30am CET
Affected services
Nango Cloud Health

Resolved
Feb 15 at 10:00am CET

Actions & syncs backlogged: issue resolved.

Created
Feb 15 at 12:30am CET

Actions & syncs backlogged: we're investigating the root cause.