Back to overview
Downtime

Downtime

Feb 25 at 09:48pm CET
Affected services
Nango Cloud Health

Resolved
Feb 25 at 10:06pm CET

Downtime: resolved.

Root cause: Our cloud provider restarted Redis during a scheduled maintenance operation. A race condition bug in Nango's Redis reconnection logic led to the creation of orphans Redis clients that eventually used all available connections, preventing any logic that depends on Redis to run successfully.

Mitigation: We fixed our Redis disconnection logic. We're investigating how to recover better from Redis's unavailability. We plan to migrate to a different cloud provider, which doesn't require database maintenance.

Created
Feb 25 at 09:48pm CET

Downtime: API/dashboard down, sync/action errors.