Back to overview
Resolved

Nango Syncs Degraded

Jun 10, 2026 at 1:24pm UTC
Affected services
Nango Cloud Health

Resolved
Jun 15, 2026 at 8:09am UTC

2026-06-11 Incident post-mortem

Summary

On June 11, 2026, part of our platform that stores the data produced by syncs began rejecting writes for a subset of syncs over a window of roughly 15 minutes. During this period, affected syncs were unable to save their fetched data and reported failures. The issue was caused by an internal change that was rolled out ahead of the component that still depended on the previous behavior.

We have fully mitigated the incident and have a concrete plan to prevent recurrence.

Customer impact

  • What: Saving of synced data failed for a portion of syncs. Affected sync runs reported errors and did not store their data during the window.
  • When: June 11, 2026, from approximately 13:13 UTC (incident start) to 13:30 UTC (mitigated), with full resolution shortly after.
  • Data integrity: No data was lost. Once the fix was in place, affected syncs resumed saving data normally on their subsequent runs.

What happened

As part of ongoing maintenance, we were retiring something internal that was no longer needed. This was planned as a multi-step rollout: first update everything that relied on it, then remove it.

During the rollout, one of those updates was missed. As a result, when the cleanup step was completed, one part of the system was still relying on what had just been removed. This caused the affected writes to fail, and the impacted syncs to error.

Resolution

We applied the missing update, after which the errors stopped immediately. Affected syncs recovered on their next run.

What we're doing to prevent recurrence

  • Ensuring changes reach every impacted component: improving our process so that a change in our codebase reliably triggers an update and rollout of all the components it affects, removing the chance of one being left running an older, incompatible version.

We apologize for the disruption. If you have questions about how this affected you, please reach out.

Updated
Jun 10, 2026 at 1:42pm UTC

We have confirmed the incident is now resolved.

Updated
Jun 10, 2026 at 1:32pm UTC

We have identified the issue and rolled out the fix. We will continue monitoring.

Created
Jun 10, 2026 at 1:24pm UTC

We are currently experiencing degraded performance in Nango syncs. We are currently investigating and will update here.