Back to overview
Degraded
Connect UI popup stuck in loading state
Jun 15, 2026 at 8:25pm UTC
Affected services
Nango Cloud Health
Resolved
Jun 15, 2026 at 9:28pm UTC
This issue has bee resolved.
Affected services
Updated
Jun 15, 2026 at 9:27pm UTC
We have identified the root cause of the issue affecting the Connect UI popup and have restored the feature. The popup now closes successfully once a connection is created.
We'll continue to monitor closely and will publish a full post-mortem later this week.
Affected services
Created
Jun 15, 2026 at 8:25pm UTC
Nango Connect UI isn't closing when a connection is successfully created.
Affected services